Allan's Blog

Cocoapods with Xcode 6 and Yosemite

COCOSPODS 就是其中一个不兼容,你的更新xcode,COCOSPODS 才可以继续用pod install

具体步奏如下

  • 打开 Xcode 6
  • Command + ,
  • 选择 Locations
  • 将 Command Line Tools version 变为 Xcode 6.0
  • 卸载 cocospods

  • $ sudo gem uninstall cocoapods
  • 安装 xcodeproj

  • $ sudo gem install xcodeproj
  • 安装 cocoapods
$ sudo gem install cocoapods
  • Run pod –version to verify that it worked

执行上面的命令之后,可能你还会失败。但是不要紧,把你Terminal的窗口关掉重新cd到你的项目在执行pod install就可以了。

Allan Chan